How to disable server url?

Discussion in 'General troubleshooting' started by goodmorningsky, Apr 14, 2011.

  1. It's not possible to remove the alternative url from your hosting account. However, you may want to consider using a URL rewrite that will perform a rewrite to your primary Domain name.

    You can view more information on our URL rewrite here
  2. How to disable site?


    http://QuoteDepot.Net is main site, but
    I found Google craws the following URL for every page of the original site.
    Here is one of the page.

    This generated URL gives very bad effect to the main site in SEO.

    The url is ranked higher than main site url, which is totally nonsense to me. I don't know how to remove the URL totally.

    I added the following to robots.txt to avoid this issue.
    User-agent: *

    But, it doesn't work.

    I start to consider moving Hosting seriously because of this problem.

    Any help?
  3. This became serious problem Now.
    The example page you linked is about redirect within the same domain.

    However, I added the following to robots.txt to avoid this issue.
    User-agent: *

    It didn't work.
    I found ranked in Google high, not my own web site. This is very bad.

    I need to resolve this issue ASAP. Otherwise I have to consider moving Hosting because of this stupid issue.
  4. mjp


    You can't disallow the alternate URL in robots.txt because it doesn't live on your domain. But Google can't crawl that URL unless you've exposed it somewhere (because we do not). Make sure you don't have a link somewhere to that alternate URL. Maybe something you set up when the account was new, during testing...

    You can't remove the alternate URL, but I don't think moving to another host is going to help. Most every host is going to provide an alternate URL to your domain. It's common practice.
  5. What's the solution?

    Hi, I've just encountered this very same problem. I notice your URL is no longer in Google... How did you remove it from Google? Did the robots.txt work?

    Don't the staff here have a solution for this one?

    Thanks for any help
  6. mjp


    The solution is to not publicly link to the alternate URL in the first place. As I mentioned, if you don't do that, Google cannot find it.

    If you already have, just make sure you remove those public links and eventually Google will drop them.

    Entries in robots.txt will not have any effect.
  7. Hello there;
    I see that you have solved your issue and I would like to know how did you do it please.
    I got rid of having the same thing with my website could you please tell me how did you solve it.
  8. How to disable url
  9. mjp


  10. "Google can't crawl that URL unless you've exposed it somewhere" Can't speak for the OP, but I've never exposed that alternate URL anywhere, and yet somehow Google keeps finding a way to crawl it.

    Regardless, if you're running on IIS7, you can use the RewriteModule to redirect requests from your alternate * URL to your actual domain.

    Add these lines to your web.config:

    		<clear />
    		<rule name="Redirect from" stopProcessing="true">
    			<match url=".*" />
    				<add input="{HTTP_HOST}" pattern="^$" />
    			<action type="Redirect" url="{R:0}" redirectType="Permanent" />
    / /.*
  11. mjp


    I understand that you believe it hasn't been exposed, but Google can only index URLs it can find.

    In any event, as you've pointed out, you can redirect, or you can contact support to disable the alternate URL.
  12. Thanks for the answers, i was looking for the same.

Share This Page