500 - Internal server error

Discussion in 'Windows 2008/IIS 7 Beta [Closed]' started by bfeller, Sep 19, 2007.

Thread Status:
Not open for further replies.
  1. am getting a "500 - Internal server error" when trying to launch my app on IIS7. I even get this message when trying to bring up a plain .htm page. I even get this ifI enter a bad url. On my local server, when I get one of these, I usually have to restart my web server or app pool, but don't know how to do this here. Not sure why I'm getting it either. The site runs fine on IIS6 site here, and runs fine on my Vista with IIS7 and Net 2.0. I can even get it to run on Server 2008 IIS7 .NET 3.5. Is there a way to look at error logsto determine cause of the 500 error?

    Thanks, Bob
  2. Can you provide your site's url to replicate the error?

    Vikram

    DiscountASP.NET
    www.DiscountASP.NET
  3. Thanks for the info. I just checked my IIS7 configuration, and did indeed have it setup to use Classic Mode. WhenI turned on integrated pipe mode, I got a similar error below.


    This handler is placed in the web.config by the 3rd party software to wrap resources(Javascripts, images)up in a dll. I will check with my vendor (Intersoft www.intersoftpt.com) to se if thiscan be run inIntegrated mode. Any possiblility ofsetting thisto run in Classic Mode for the time being? I'mgoingto try some things on my IIS7 server, see what happens if I place this handler in the <system.webServer>/<handlers> configuration section, and let you know.


    Thank you, Bob


    ------------------- Error from IIS7 running on Vista Enterpise ---------------


    In this mode, the application should not specify ASP.NET handler mappings in the <system.web>/<httpHandlers> configuration section. Instead, it should use the <system.webServer>/<handlers> configuration section to configure ASP.NET handler mappings.
    1) Migrate the application to work with the Integrated .NET mode (PREFERRED).


    You can migrate the application configuration, including the contents of the <httpHandlers> configuration section, by using the following from a command line window (the window must be running as Administrator):

    %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "Default Web Site/Smartrack"

    After you migrate your application, it will run in both Classic and Integrated .NET modes, as well as on downlevel platforms.
    2) Move this application to an application pool using the Classic .NET mode.


    You can move the application to an application pool that uses the Classic .NET mode by using the following from a command line window (the window must be running as Administrator):

    %systemroot%\system32\inetsrv\APPCMD.EXE set app "Default Web Site/Smartrack" /applicationPool:"Classic .NET AppPool"

    Alternatively, you can use any other application pool on your system that is running in the Classic .NET mode. You can also use the IIS Administration tool to move this application to another application pool.


    ....
  4. DannyT

    DannyT DiscountASP.NET Staff

    I had set your application pool to Classic .NET pipeline for the time being and your webpage is working fine. You should also be able set individual modules to function in Integrated or Classic mode. I know I am able to change modules from Classic to Integrated, but never tried the reverse. I had an article previously which hits that subject a little, hope it helps!:


    Remove/Add modules to use Integrated Pipeline:
    1. Add this into your root web.config file between the <system.webserver> tags like below. The modules comes with a precondition (backward compatibility) to apply to content that is handled by the managed handler. This will remove the current authentication modules and add them back in with the with the preconditions removed. The process was to remove the precondition, I believe if you add the precondition back, it would function as Classic .NET.

    http://community.discountasp.net/default.aspx?f=28&amp;m=16821

    <modules>
    <remove name="FormsAuthenticationModule" />
    <add name="FormsAuthenticationModule" type="System.Web.Security.FormsAuthenticationModule" />
    <remove name="UrlAuthorization" />
    <add name="UrlAuthorization" type="System.Web.Security.UrlAuthorizationModule" />
    <remove name="DefaultAuthentication" />
    <add name="DefaultAuthentication" type="System.Web.Security.DefaultAuthenticationModule" />
    </modules>



    Chow
    DiscountASP.NET
    <SUB><SUP>http://DiscountASP.NET
  5. Bruce

    Bruce DiscountASP.NET Staff

    i tested the page on the server. This is the error


    HTTP Error 500.23 - Internal Server Error
    An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

    <FIELDSET><LEGEND>Detailed Error Information</LEGEND>




    Module
    ConfigurationValidationModule

    Notification
    BeginRequest

    Handler
    StaticFile

    Error Code
    0x80070032




    Requested URL
    http://beta-406505.lhweb3.iis7betahosting.net:80/

    Physical Path
    e:\web\beta-406505\htdocs

    Logon Method
    Not yet determined

    Logon User
    Not yet determined
    </FIELDSET>

    <FIELDSET><LEGEND>Most likely causes:</LEGEND>
    • This application defines configuration in the system.web/httpHandlers section.
    </FIELDSET>

    <FIELDSET><LEGEND>Things you can try:</LEGEND>
    • Migrate the configuration to the system.webServer/handlers section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using appcmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.
    • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
    • Alternatively, switch the application to a Classic mode application pool - for example, appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.
    (Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name) </FIELDSET>

    Bruce

    DiscountASP.NET
    www.DiscountASP.NET
  6. Thanks. You guys have very good support. I will read that article, as I would like to be able o run my app in full Native integrated mode. I sent an email to my vendor on this issue, but still awaiting a reply. I will keep you posted.

    Thank you, Bob
  7. I've got the same problem. The application works fine on my IIS 6.0 accounts. The app is written in Classic ASP and uses an Access DB at the moment. Here is a link to the site. http://beta-421100.lhweb3.iis7betahosting.net/realestate/index.asp


    I've downloaded the IIS 7.0 Manager from Microsoft and I've requested access through support, but they won't help me.


    Thanks, Brian
  8. Sorry, I get the 500 error when I try to login. I can pull up the main login screen, I just can't login. Thanks, Brian
  9. Bruce

    Bruce DiscountASP.NET Staff

    hmmm... i need to do some research to see how you can display the complete error on iis7


    Bruce

    DiscountASP.NET
    www.DiscountASP.NET
  10. Bruce

    Bruce DiscountASP.NET Staff

    OK.. this is the deal.


    1) IIS 7 beta3, by default, do not display the real error to the browser. see
    http://blogs.iis.net/thomad/archive/2007/02/06/security-is-painful.aspx

    I have updated the setting on your site to force the error to be displayed to the browser.

    2) The cause of the error is -->> Access driver is not installed with windows 2008. I found that only SQL driver comes bundled with the server.

    Bruce

    DiscountASP.NET
    www.DiscountASP.NET
  11. Thanks Bruce! I will wait for your next response. I've literally installed this code on 4 different IIS 6.0 shared accounts at discountasp and I have no problems whatsoever. Brian
  12. So, can we use Access on this box? Can the driver beinstalled?


    Thanks, Brian
  13. Wow, I did not know that. [​IMG]
  14. Bruce

    Bruce DiscountASP.NET Staff

    I am working w/ the Windows 2008 GoLive team on this problem. It looks like the problem is with 64 bits version of the OS.


    I think it will work when iis7 releases. I don't think there's anything we can do in the beta env though.


    Bruce

    DiscountASP.NET
    www.DiscountASP.NET
  15. Thanks! Should I make other arrangements in the meantime?
  16. Bruce

    Bruce DiscountASP.NET Staff

  17. The link resolved for me also but if you click the image button login.asp results in a server error.
  18. Bruce

    Bruce DiscountASP.NET Staff

    I think you can assumed that Access DB connection will not work on the beta server.


    Bruce

    DiscountASP.NET
    www.DiscountASP.NET
Thread Status:
Not open for further replies.

Share This Page